Moodle 3.7 or later requires at least PHP 7.1.0 (currently using version 7.0.33-11+ubuntu16.04.1+deb.sury.org+1). Some servers may have multiple PHP versions installed, are you using the correct executable?